Upgrade manual la WordPress


Deși începând cu versiunea 2.7 a WordPress avem posibilitatea de a upgrada automat blogul nostru, nu strică niciodată să avem idee cum anume se face actualizarea manuală. Așa ne vom însuși câteva cunoștințe noi ce ne vor prinde bine mai târziu: ce este un client FTP și cum se folosește, ce fișiere/foldere conține o instalare de WordPress, etc.

Înainte de a începe aveți nevoie de un client FTP (recomandare mea este Filezilla pe care l-am prezentat de curând) și datele contului de FTP asociat domeniului vostru. Pe acestea din urmă le-ați primit în momentul setării contului de găzduire, cel mai probabil. Acum este timpul să trecem la treabă, sunt doar câțiva pași simpli. Ca de obicei, dacă nu am explicat ceva îndeajuns nu ezitați să întrebați.

  1. Fă un backup al bazei de date și al contului de FTP – pur și simplu downloadează toate fișierele din httpdocs sau public_html.
  2. Downloadează și dezarhivează local ultima versiune WordPress. Pentru dezarhivare poți folosi 7zip, un manager de arhive gratuit, rapid și ușor de folosit.
  3. Dezactivează toate pluginurile, absolut toate pluginurile!
  4. Conectează-te la contul de FTP și șterge toate fișierele și folderele cu excepția următoarelor:

    a) Fișierul wp-config.php ce conține datele de conectare la baza de date.

    b) Fișierul .htaccess pentru regulile de Nice URLs.

    c) Fișierele de genul robots.txt, sitemap.xml și sitemap.xml.gz

    d) Folderul wp-content; dacă folosești un plugin de cache trebuie să ștergi conținutul folderului wp-content/cache

    e) Folderul wp-content/languages dacă folosești o traducere a WordPress.

  5. După ce ai terminat de șters tot mai puțin excepțiile de mai sus, uploadează conținutul folderului WordPress rezultat în urma dezarhivării arhivei downloadate în pasul 2.
  6. Upgradează WordPress navigând la adresa http://domeniultau.ro/wp-admin/upgrade.php și urmând instrucțiunile.
  7. Dacă nu ai făcut-o până acum poți vizita și pagina de compatibilitate a pluginurilor cu WordPress 2.8. Versiunea pe care o așteptăm să fie lansată este, la momentul actual, 2.9 dar cum este un feature release cel mai probabil mare parte din pluginurile care au funcționat cu versiunea actuală nu vor avea nicio problemă. Reactivează pe rând pluginurile.

În acest moment, în caz că nu au apărut oarecare necompatibilități între pluginuri și noua versiune WordPress ar trebui să ai un blog funcțional și actualizat. Pentru orice s-ar putea întâmpla restaurează backup-urile realizate anterior.


Apreciază articolul:

1 stea2 stea3 stea4 stea5 stea (3 evaluări, media: 5,00 din 5)
Loading...Loading...

13 comentarii

  1. Multumesc mult pentru articol. Chiar este de folos in caz ca uiti sa faci ceva…

  2. Cristi spune:

    Eu folosesc numai metoda manuala de actualizare. Asa m-am obisnuit sa fac si ma gandesc ca e mai sigur asa. Am o nelamurire in legatura cu directorul languages. L-am pus o vreme in wp-includes dupa care l-am mutat in wp-content si in prezent e iar in wp-includes. Am facut diverse modificari dupa citirea unor tutoriale… Unde trebuie pus folderul languages?
    Va urmaresc mereu si am invatat multe chestii utile de la CNet.ro. Multumesc si succes in continuare!

  3. Păun Eugen spune:

    Oriunde dintre cele doua locatii wp-content sau wp-includes va functiona la fel de bine.

    Personal folosesc wp-content, deoarece in cazul unui upgrade nu voi sterge folderul respectiv din greseala. La fel unele pluginuri de upgrade automat, gen WordPress Automatic upgrade, fac backup numai la wp-content si iti ofera acest backup spre download.

  4. Tuns Paul spune:

    Salut! Am şi eu o întrebare. Dacă fac upgrade manual, widgeturile şi unele setări se vor şterge şi voi fi nevoit să le refac?

  5. Păun Eugen spune:

    In mod normal, nu ar trebui sa fie nicio problema. Setarile pentru widgeturi si pluginuri se vor pastra in baza de date. Exista doar situatii speciale – incompatibilitati ale unor pluginuri, pluginuri ce necesita modificari ale fisierelor core wordpress, in care vei pierde astfel de setari.

    Oricum nu uita sa faci backup inainte de orice upgrade, fie al wordpress, fie al unor pluginuri.

  6. radu.capan spune:

    Că faci upgrade manual sau automat e tot acolo. Modul manual merge mai „orbeşte”: ştergi fişierele vechi, pui tot setul nou. Modul automat şterge doar ce fişier s-a schimbat, publicând doar fişierele nou schimbate. Per ansamblu tot una e, deci nu are cum upgrade-ul manual să facă mai mari probleme decât cel automat.
    Oricum ar fi, upgrade-urile nu modifică setările personale.

  7. bogdan cercel spune:

    A mers! Yupiii. Multam fain pentru guideline. Nu mai voia sa miste pe automat si chiar nu stiam ce si cum. M-ati luminat! Felicitari!

  8. bogdan cercel spune:

    Uite ca revin. :( Ma puteti ajuta c-un sfat? Am reinstalat tot, dar, evident, am uitat sa sterg folderul cache (la mine se afla pe traiectul wp-content/uploads/cache). Si acum nu-mi mai merge ragalia. Adica pozele nu le mai afiseaza cum trebuie. Aveti o recomandare? Sau sa reinstal din nou? Multumesc.

  9. bogdan cercel spune:

    Am rezolvat! Erau cateva fisiere de la un plugin (viva) care trebuiau repuse pe server. Multumesc!

  10. stefan spune:

    Am urmat tutorialul dar acum nu mai pot intra in cPanel. Zice Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 30720 bytes) in wp-admin/includes/post.php on line 974.

  11. Păun Eugen spune:

    În primul rând, faci o confuzie. cPanel este un panou de control al contului de găzduire.

    Apoi, e posibil ca hosterul tău să fi setat memory_limit prea mică, la 32 Mb. Încearcă să mărești limita cu htaccess sau mai dezactivează din pluginuri.

  12. buratino spune:

    Salut. Am si eu o problema nu prea ma pricep si vreau sa uploadez pluginul kimili, dar problema e ca habar nu am cum sa ma conectez pe contul de FTP. Ma ajuta cineva?

  13. vali spune:

    La mine nu merge sa fac update automat din cauza hostingului.


Lasă un răspuns

Adresa ta de email nu va fi publicată. Câmpurile necesare sunt marcate *