Şi wp-config.php mai cere actualizări


Dacă aveţi situri realizate cu WordPress vechi de câţiva ani, chiar dacă le-aţi actualizat constant, şi acum sunteţi la versiunea 3.1, rămâne un fişier problematic: wp-config.php. De ce? Pentru că actualizările WordPress nu îşi permit să se atingă de acest fişier. Am deschis fişierul de configurare la un sit WordPress instalat acum 3-4 ani: avea sub 30 de linii… astăzi fişierul are aproape 90 de linii. Da, da, multe sunt comentarii, iar esenţa este evident aceeaşi: numele bazei de date, numele utilizatorului, parola şi eventual serverul MySQL (cel mai adesea localhost). Sunt totuşi şi linii noi, care nu existau acum câţiva ani.

imagine

De aceea, dacă folosiţi de mult timp WordPress ar fi foarte indicat să faceţi manual actualizările la fişierele wp-config. În special pentru a rezolva cheile unice de autentificare – acestea au rolul de a face mai grea viaţa hackerilor ce speră să vă spargă situl prin intermediul “prăjiturelelor” (nu pot uita conferinţa la care am participat şi conferenţiarul repeta obsesiv “prăjiturele, prăjiturele” referindu-se la cookies). După cum se vede parţial din captura de mai sus, WordPress.org pune la dispoziţie un generator, aşa că nu e greu de rezolvat rapid cu respectivele chei. Evident, nimeni nu vă opreşte să puneţi ce text doriţi Dvs, dar cu generator e şi mai sigur, şi mai rapid.

imagine

Pentru a face actualizarea fişierului wp-config.php vă recomand să descărcaţi ultimul kit de la ro.wordpress.org, de unde să deschideţi wp-config-sample.php. Editaţi fişierul cu un editor text (mutând datele de acces la baza de date şi orice alte linii aţi mai introdus manual de-a lungul timpului acolo) dar… doar dacă ştiţi ce faceţi. Dacă sunteţi începător poate e mai bine să apelaţi la un prieten cunoscător.


Apreciază articolul:

1 stea2 stea3 stea4 stea5 stea (Neevaluat încă)
Loading...Loading...

0 comentarii


Lasă un răspuns

Adresa ta de email nu va fi publicată. Câmpurile necesare sunt marcate *